XFCE no apaga el equipo con systemd

el equipo no se apaga bienReceta corta para aquellos que, como yo, se han encontrado que al actualizar su sistema (en mi caso ArchLinux) a systemd han comprobado, con horror, que sus ordenadores ni reiniciaban ni se apagaban correctamente teniendo que recurrir a mantener pulsado el botón de “encendido” más tiempo del deseable 😉

Tras buscar infructuosamente en los logs (y utilizar el nuevo journalctl) y no encontrar en la web algún alma caritativa que se hubiese topado con el mismo problema (y que me evitase tener perder invertir tiempo averiguando cómo solucionarlo ¿¡¿no puedo ser el primero al que le haya pasado?!?) he optado por regalaros la solución que le he dado al asunto por si os ocurre lo mismo y queréis salir rápido del atolladero.

Origen del problema

Debí haberlo imaginado antes pero, para variar, fue lo último que miré (¿os suena?)

Como se trataba del netbook (recursos MUY limitados) estoy utilizando XFCE4 con SLIM. Y aquí estaba el problema: en los comandos que tiene configurado slim para el reboot y halt.

Solución

Sólo tenemos que modificar el fichero /etc/slim.conf sustituyendo las líneas

halt_cmd /sbin/shutdown -h now
reboot_cmd /sbin/shutdown -r now

por el siguiente contenido

halt_cmd /usr/bin/systemctl halt
reboot_cmd /usr/bin/systemctl reboot

Conclusión

Forma sencilla de evitar que nuestro equipo se quede colgado al intentar apagarlo una vez que hemos cambiado a systemd.

Espero que os sea de utilidad y os evite perder más tiempo del imprescindible tratando de averiguar por qué se queda el ordenador colgado mostrando la terminal y sin otra posibilidad que dejar pulsado el botón de “power” para apagarlo.

Por cierto, ¿cuántos de vosotros usáis slim frente a otras soluciones como GDM o KDM?

11 comentarios en “XFCE no apaga el equipo con systemd

  1. A mi me pasa exactamente lo mismo que a ti: uso XFCE con SLIM, y desde hace unos días no hay manera de apagar bien, así que tiraba de consola:

    sudo shutdown -h now

    Claro, no es lo mejor. Tampoco lograba encontrar soluciones sencilllas al problema, y me hice la misma pregunta que tú: ¿Será posible que nadie tenga este mismo problema antes que yo?

    Gracias por la solución.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s