backup automáticos mikrotik

Backup Automáticos en #Mikrotik


Todos hemos tenido esos momentos donde de repente falla el sistema y pensamos: “A ver si tengo un backup por ahí…” Pero tras buscar y buscar nada. Y ahora es cuando reniegas e intentas acordarte de cómo hiciste aquello o lo otro, o buscar apuntes y notas de cuando lo hiciste. Evitemos eso, Vamos a hacer backups automáticos y enviarnos al email.

Todos los parámetros y acciones los realizamos a través del winbox o del terminal.

Lo primero es configurar una cuenta de correo electrónico para poder enviarnos las copias de seguridad. Recientemente, publicamos un artículo explicando cómo usar una cuenta de Gmail como servidor SMTP en Mikrotik por si necesitas configurarlo.

Vamos a probar los comandos que utilizará el script, para ver paso a paso lo que hace:

Primero creamos el backup:

/system backup save dont-encrypt=no name=[Nombre backup]

Y como ya tenemos configurado el envío de email, lo adjuntamos y nos lo enviamos:

/tool e-mail send to=nuestroemail@dominio.com subject="Backup mikrotik" file=[Nombre bakckup]

Si todo ha salido bien, debemos tener el backup inicial en nuestro correo.

Ahora toca pasarlo a un script, para ello, desde el menú de systems/scripts, añadimos un script:

Nombre, backup by email

En source pegamos los comandos que probamos antes:

/system backup save dont-encrypt=no name=[Nombre bakckup]</pre>
/tool e-mail send to=email@domain.com subject="Backup mikrotik" file=[Nombre bakckup]

Por comandos:

/system script add name="Backup al email" source="/system backup save dont-encrypt=no name=Nombre /tool e-mail send to=email@domain.com subject=[Backup mikrotik] file=[Nombre bakckup]"

Y una vez tenemos el script, el siguiente paso será hacer la programación,

Se hace desde /system scheduler, damos al +, y en la ventana ponemos el nombre que queremos, la fecha y la hora en que se inicia, o si ponemos startup será cada vez que se reinicie. En interval cada cuánto queremos que se ejecute, podemos indicar:

  • En horas, por ejemplo, 36:00:00, cada 36 horas
  • En días, por ejemplo, 10d 00:00:00, cada 10 días

Y lo más importante, en “On Event”, debemos poner el nombre del script, En el ejemplo que estamos realizando es: “backup by email”, si lo queremos poner por comandos, este es:

/system scheduler add name="backup al email" start-date=jul/04/2019 start-time=00:00:00 interval=10d on-event=backup

Próximamente os enseñaremos cómo recuperar un mikrotik desde cero y cargar el último backup que tengamos. Y el uso del sistema seguro para modificar cualquier parámetro.

CONCLUSIÓN

Este punto de generar backups automáticos diría que es de los más importantes y entraría dentro de las llamadas nociones básicas. Disponer de un sistema de backup antes incluso de securizar el sistema nos permite que por una modificación mala o errónea nos evitemos el resetear completamente el mikrotik y realizar todo desde 0, de esta manera siempre tendremos una copia con los últimos cambios que realizamos.

Y TÚ…

  • ¿Haces backups?
  • ¿Prefieres usar el mikrotik por winbox o por ssh?
  • ¿Qué te ha parecido…?

Un comentario en “Backup Automáticos en #Mikrotik

  1. Enhorabuena y gracias amigo Whanjo por regalarnos el tiempo necesario para redactar este artículo que, a buen seguro, nos será de gran utilidad a muchos de nosotros.

    Yo por mi parte voy activando el backup por lo que pueda pasar.

    Deseando estamos de seguir aprendiendo trucos para sacar el máximo partido a nuestros dispositivos Mikrotik 👍🏻

    Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .